Optimizing Your Prints: Print Steps, File Settings & More

Follow

Table of Contents

Simplify Strokes

When to simplify strokes

When creating or using a design in a vector format, such as an SVG file, objects in the design are created using strokes, fills and images. A stroke is an outline and a fill is just a filled-in stroke. When you upload your file, strokes become cuts and fills become engraves. You can then switch a stroke to a score so that your Glowforge will draw a line instead of cutting.

Nodes are the points which connect strokes together. When a design is very complex or contains a high number of nodes, this can increase loading and print processing times in the Glowforge app, or even cause a print to fail. If a print fails for this reason, it will stop during the “Preparing your Print” stage. Both Inkscape and Illustrator can simplify a design by decreasing the number of nodes.

Knowing how to simplify strokes is especially handy for people who export designs from CAD software packages, as exporting a sketch or profile often results in many nodes. This guide will help you reduce the number of nodes for the best results when uploading to the app!

Simplify strokes in Inkscape

  1. Click the selection tool Inkscape_Selection_Tool.png and then select an object from your design.

  2. Switch to the node tool by pressing F2 to view the nodes in the design
    Nodes-Many-Inkscape.png
  3. In the menu bar, click Path > Simplify
    Nodes-Few-Inkscape.png

  4. Repeat for any other objects or strokes you wish to simplify

Simplify strokes in Adobe Illustrator 

  1. Click View > Outline to switch to the outline view.
    Default_vs_Outline.jpg
  2. Click on the Selection Tool Illustrator_Selection_Tool.png and then select an object from your design to see its nodes. 
    Screen_Shot_2020-03-13_at_3.56.16_PM.png
  3. Click Object > Path > Simplify.

  4. Click the 3 dots on the right to expand the settings.
    Screen_Shot_2020-03-13_at_3.56.56_PM.png
  5. Click “Show Original Path” to compare your changes to the original shape. 
    Screen_Shot_2020-03-13_at_3.58.19_PM.png
  6. If your design doesn’t look as expected at first, don’t worry! Illustrator will remove nodes when you simplify a path, and it might not choose the right ones to remove at first. If it doesn’t look right, adjust the sliders until you’re happy with the result.
     Screen_Shot_2020-03-13_at_4.00.54_PM.png
  7. Click “OK”

  8. To return to the default view, in the menu bar, click View > Preview

Repeat this process for any other objects or paths you wish to simplify.

Return to Table of Contents

 

Rasterize Objects (Converting Vectors to Bitmaps)

What is rasterizing?

Rasterizing is the process of taking an object which is stored as series of strokes and fills in an SVG or other vector file and converting the object into an image made up of individual dots (or pixels). Rasterized images, also called “Bitmaps,” can only be engraved, not cut or scored. PDF and SVG files can contain both vectors and raster images. 

There are some scenarios, however, where you might want to rasterize all or part of your design instead. Here are two examples of when rasterizing can be useful:

  • Very complex engraves can upload and process more quickly as bitmaps, so your amazing print will be ready sooner. 
  • When you upload a file to the Glowforge app, stroke weight (thickness) or any stroke styles such as dotted or dashed lines are preserved if your design is a bitmap, and that means your vision will be realized. 
  • Some vector features like gradients and live shapes work best when rasterized.

 

How to rasterize objects in Inkscape

  1. Open your design in Inkscape.

  2. Open the preferences menu by clicking Edit > Preferences
    Preferences_Location_Inkscape.png
  3. In the window that opens, navigate to the Bitmap settings. Enter a dpi value in the "Default export resolution" and "Resolution for Create Bitmap Copy" fields following the example below.

    Files with a large number of high-resolution images will take longer to upload and to be prepared for printing in the app. Most customers find that their prints turn out beautifully with a dpi of 300. 
    Bitmap_Settings_Inkscape.png

  4. Close the Preferences window.
  5. Click on the selection tool Inkscape_Selection_Tool.png, and then choose the object or objects you want to rasterize.

  6. With the object(s) selected, click Edit > Make a Bitmap Copy.
    Inkscape_Rasterize_Pt1.png

  7. A copy of the object will appear as a new raster layer. 

  8. To delete the vector layer, click Object > Lower to Bottom, then click on your shape again and press the delete key.
    Inkscape_Rasterize_Pt2.png

 

How to rasterize objects in Adobe Illustrator

  1. Open your design in Illustrator.

  2. Click the Selection Tool  Illustrator_Selection_Tool.png and then choose the object or objects you want to rasterize.

  3. With the object selected, from the menu bar click Object > Rasterize
    Illustrator_Rasterize_Pt1.png

  4. In the window that opens, choose a resolution. Files with a large number of high-resolution images will take longer to upload and to be prepared for printing in the app. Most customers find that their prints turn out beautifully with a dpi of 300.
    Illustrator_Rasterize_pt_2.png

  5. Click “OK”

 Return to Table of Contents

Print Thick or Stylized Strokes

What is a stylized stroke?

When creating a vector design, many programs have the option to adjust the thickness of a path or apply stylized strokes to paths. Using stylized strokes is an easy way to create beautiful line-work in designs. In the following example, several different styles have been applied to the same line:

Stroke_Examples.png

Designs containing thick strokes or stroke styles might not load as expected in the Glowforge app.

There are two ways to ensure your design comes out the way you intended:

Converting Strokes to a Bitmap 

For some stroke styles, converting the stroke to an outline might not be a good option as it would create objects which are very complex or have a high number of nodes. This could lead to slowing the upload and processing time for your design. The following are examples of stroke styles which might not work well as an outline:

Screen_Shot_2019-12-27_at_11.25.37_AM.png 

Taking a closer look at the example on the left, when it’s outlined it results in a very complex design with many individual nodes:

Screen_Shot_2019-12-27_at_11.26.58_AM.png

For paths using styles similar to these, convert to a bitmap by rasterizing them. A guide to rasterizing vector objects can be found here.

Converting Strokes to an Outline 

For strokes that you want to engrave with a specific thickness and simple shape, convert them to outlines using Adobe Illustrator or Inkscape.

 

In Inkscape:

  • Click the selection tool Inkscape_Selection_Tool.png, and then select the stroke(s) you want to outline.

  • In the menu bar, click Path > Stroke to Path.
    Screen_Shot_2019-12-27_at_11.21.26_AM.png

  • If you now switch to an outline view by clicking Menu Bar > View > Display Mode > Outline you’ll see that your stroke now has a closed path around it.
    Screen_Shot_2019-12-27_at_11.22.49_AM.png

 

In Adobe Illustrator:

  • Click the Selection Tool Illustrator_Selection_Tool.png, and then select the stroke(s) you want to outline.

  • In the menu bar, click Object > Path > Outline Stroke
    Screen_Shot_2019-12-27_at_11.12.02_AM.png

  • If you now switch to the outline view by clicking Menu Bar > View > Outline you’ll see that your strokes now have a closed path around them.
    Screen_Shot_2019-12-27_at_11.15.03_AM.png

 

Once you’ve outlined a stroke in Inkscape or Adobe Illustrator, you’ll no longer be able to edit its thickness or style.

Once this is saved as an SVG and uploaded into the app, the stroke now appears as an outline which can easily be cut, engraved or scored:

Screen_Shot_2020-02-14_at_9.29.29_AM.png

Return to Table of Contents 

Advanced: Setting the Order of Your Print Steps

Introduction

When creating a design Glowforge app, each color becomes a different step in the printing process. This lets you change their print settings and the order in which they’re printed. 

Sometimes cutting an object before you engrave it can cause the object to move slightly. Other times, you may want to start the print with a complex engraving, and interrupt it if you’re not happy with the results. This guide walks through the process of ordering your print steps.

Print Step Order Practices For Complex Designs


As a general rule, it’s best to start with the elements closest to the center of your design and then work outward when cutting. When a shape is cut out, it’s possible for the following to happen:

  • The position of the material which has been cut out might shift due to the material dropping down after being cut out.

  • The edges of the material may curl if printing on something flexible like Proofgrade Leather or Veneer.

In either of the above examples, if an engrave or score were to take place on the material after its position or shape has changed slightly after being cut out, this could lead to areas of the finished print being slightly misaligned or out of focus. (While we’re talking about materials, you can read about Materials Safety here.

 
Changing the Order of Print Steps Manually

The simplest way to set up the order of your print is to adjust the steps in the app. Here’s an example using the following design for a picture frame:
Screen_Shot_2020-01-08_at_10.55.04_AM.png

The design has text and multiple closed paths, all using the same color. For the purpose of this example, the text is to be engraved, the border around the photo is to be scored, and the holes in the corners, the opening for the photo and the border are all to be cut.

The following print step order would help to ensure that all steps have the best focus and positioning:

  • Engrave the text
  • Score the outline path
  • Cut the corner holes and photo opening
  • Cut the outer border

If everything in this design is left the same color, they will all be one step. To make it into separate steps and arrange the print order: 

  1.  Assign each element of the print a corresponding color:
    Screen_Shot_2020-01-08_at_10.58.12_AM.png
  2.  Save the SVG so it can be uploaded to the Glowforge app. If you’re wondering about the best settings to use when saving the SVG in Inkscape or Illustrator, please refer to our quick guide here.

  3. Upload the file to the app. You will see the separate steps.
    Screen_Shot_2020-01-09_at_2.29.29_PM.png
  4. Click and drag each step shown on the left to rearrange the order in which the steps will print. In the following image, this print has now been set up to engrave, score and then cut in a specific order.
    Screen_Shot_2020-01-09_at_2.29.55_PM.png
  5. Print! When this design is sent to be printed, it will print in the order shown from to bottom. First it will engrave the text, next it will score the border line around the photo, then it will cut out the photo area and corner holes and finally it will cut out the outline of the frame.


Creating Designs With Automatically Ordered Steps


Designs can be created so that they will automatically upload into the Glowforge app in a desired order. When a vector design is loaded in the app, certain colors are always loaded before others. 

Here is a handy chart containing a list of colors and their RGB values showing the order in which they’ll show up in your print steps:
Color_Order_Revised.png
 
In the left image below, each number has been set to its corresponding color from the chart above. The right image demonstrates how the elements appear when the file is uploaded into the app.

 Color_Order_Revised_in_app.png

We can use the same photo frame shown earlier in this article to demonstrate using colors 1, 2, 3 & 5 from the chart: 
Screen_Shot_2020-02-14_at_9.09.26_AM.png

  • With the colors used in this example, the design will automatically load with four steps. 
     Screen_Shot_2020-01-09_at_2.29.55_PM.png
  • When this file is uploaded, it immediately shows the same order we achieved by clicking and dragging the steps earlier in this guide.  

Return to Table of Contents
 

Quick: Saving SVG Design Files

 

Introduction

When saving a file as an SVG in Illustrator or Inkscape, the following settings lead to the most reliable prints.


SVG Settings - Inkscape 

To save your design as a plain SVG in Inkscape:

  • In the menu bar, click File > Save As.
  • In the window that opens, select “Plain SVG” from the drop-down menu.

 Inkscape_Plain_SVG.png

  • Name your file and click “Save”

SVG Settings - Adobe Illustrator 

To save your design as an SVG in Illustrator

  • In the menu bar, click File > Save As.
  • In the window which opens, use the settings shown in the following screenshot:
    Illustrator_Settings.png

  • Click “OK”

Return to Table of Contents
 

Combine Overlapping Vector Objects


Introduction

When a vector design file such as an SVG contains multiple overlapping objects, this can sometimes cause a design file to not load as expected in the Glowforge app. In the following example, the shape may look like a single solid fill when viewed in design software. However, when only the outlines of the vector objects are visible, it shows that the design is made out of multiple overlapping shapes.

 Screen_Shot_2019-12-27_at_1.22.07_PM.png

When a file with overlapping shapes is uploaded to the app and printed, this can cause the areas where there is overlap to be excluded from the print:

Overlapped.jpg

 

Combining Shapes Before Saving

If your design is meant to be engraved, you can easily combine the shapes into a single object by rasterizing them. You can find a guide on how to rasterize objects here. 

If you want to cut out the outline of the parts of your design that overlap, or if you’d prefer to keep your design as a vector object, you can use a tool to combine them into a single shape in either Adobe Illustrator or Inkscape.

In Inkscape:

  • Select the objects you want to combine into a single shape.
  • From the menu bar, click Path > Union.
    Screen_Shot_2019-12-27_at_1.43.04_PM.png

  • If you switch to the outline view by clicking Menu Bar > View > Display Mode > Outline, you’ll be able to verify that you now have a single object  instead of four overlapping ones.
    Screen_Shot_2019-12-27_at_1.43.47_PM.png

After combining the objects which overlap, you can then save your file, upload it to the app, and print it! The following photo shows how the example design prints before and after combining the shapes:

Before_and_After.png

In Illustrator:

  • Click Window > Pathfinder to open the pathfinder window. Select the objects you want to combine into a single shape.
  • In the Pathfinder Window, select the “Unite” shape mode.
    Screen_Shot_2019-12-27_at_1.36.24_PM.png

  • If you switch to the outline view by clicking Menu Bar > View > Outline, you’ll be able to verify that you now have a single object instead of four overlapping ones.

    Screen_Shot_2019-12-27_at_1.37.59_PM.png

After combining the objects which overlap, you can then save your file, upload it to the app, and print it! The following photo shows how the example design prints before and after combining the shapes:

Before_and_After.png

Return to Table of Contents